Choppy Playback in Adobe Premiere Pro

Viewing 0 reply threads
  • Author
    Posts
    • #89282
      abitofbs
      Participant

      I’m having a problem with choppy playing of clips that seemed to begin with the latest update of Premiere Pro CC. This is playback of footage that’s been imported with no effects on it:

      This happens with any clip that I’ve recorded on multiple cameras and formats including a Canon T3i, iPod Touch, iPad Mini and a Moto X phone. My system is a Core i7 running Windows 7 64-bit with 32 GB of RAM, The graphics card is a Nvidia GeForce GT640 with 2 GB of RAM.

      I’ve updated the graphics card driver, cleared the media cache, lowered playback resolution and tried working with or without Mercury Engine GPU acceleration and that didn’t solve the problem. The scratch disks are the same as the project and that drive has 438 GB of 1 TB available.

      Thanks in advance for your suggestions for a fix.

      Bob Seybold

Viewing 0 reply threads
  • The forum ‘Open Forum’ is closed to new topics and replies.

Best Products

The best digital storage for video editors — 2021

As digital video resolutions increase, our need for storage increases as well. If you’re ready to step up to a new storage solution, you’re in the right place.
homicide-bootstrap

Need help making a stellar first video?

FREE

Download our free eBook with 8 tips to get on the right track and create a video that you can be proud of.

Giveaway

THE ESSENTIAL VLOGGING TOOLKIT

Given away to one lucky winner

Competition is open worldwide

ENTER TO WIN