Shaky highspeed video after rendering in Vegas 11

Videomaker – Learn video production and editing, camera reviews Forums Technique Editing Shaky highspeed video after rendering in Vegas 11

Viewing 6 reply threads
  • Author
    Posts
    • #47510
      AvatarAnonymous
      Inactive

      Hi there,

      I shot some ball hockey video with a GoPro cam at 960p/48fps. The files right off the camera look great. Sharp and smooth. While I’m editing in Vegas Pro 11 all looks good but for the life of me, I can’t get a decent output. It’s all very shaky/jittery video when the goaltender moves his head around and players are zipping in and out of the shot.

      I’ve tried numerous formats and framerates but I can’t get a decent result. Any advice out there from some seasoned veterans?

      I threw the video to YouTube, where it looks relatively the same as what I get in my rendered MP4s/AVIs/WMVs, etc.: http://youtu.be/ZUYhDVDP_Rs?hd=1

      Thanks!

    • #195840
      Avataroldnick
      Participant

      I am not a seasoned veteran, except at getting shaky video :), finally in Vegas (Studio) but before that in many other softwares, when working with a 50p source.

      I also have wonderful output from my camera (and beneath your jitter I can see that your GoPro has certainly done a good job. I think they have improved scarily)

      I wanted to have the ability to go to DVD, other people, Youtube, etc. So asking me, what my intentions were for the output, was (common and) largely useless.

      I struggled to get answers I understood, because they were usually so far above my noob level of understanding, but in the end I have started to get some good results. There was also a lot of often completely conflicting advice, none of which worked, when I could understand it. Maybe I can help.

      I am a bit verbose !, but I am willing to put in the time each reply to either help, or get others to help.

      I am pretty sure I know exactly the problem you are getting. I have nearly solved it and perhaps I can start you off, so we can work together on this.

      SO. Some initial questions.

      Have you
      tried rendering Interlaced ? (AFAICS upper field first or LFF work
      equally, but I am sure that this will be wrong as I diversify play
      places).
      (This worked for me, but I only suggest you
      try it. As soon as I posted to YT, YT failed to deinterlace and that was
      that Vegas needs progressive output).

      You start at 960 48p. What are some of the
      renderers you tried in Vegas? What player(s) have you used? What result do you get if you save at the native frame rate?…hmmmmm…I do not think you can…maybe try another fast frame rate..

      I suggest naming your test files with the details of the render. so “mpeg-2 25p 720 400 ” mpeg-2 25i T (op)F (rame)F (irst) 700 400″ etc

      Grab a programme called MediaInfo. It gives you all the info about a video, just like a really good metadata (exif) reader for still shots.

      It should install as a Windows right-click menu item, so all you need to do is right click on the video you want, the ask for MediaInfo. It will pop up a DBox showing all the data. You can then export to text (File/Export, then choose the Txt tab. Tick Advanced Mode. Pick a location from the little browse button then hit hit Save, then OK back in the main MI window. This _should_ save, but a few times I have had it miss fire and I had to have another go.

      If you post the result of both your input file and the output file here, that can help people help you….Maybe not me! but as I said I can at least start.

      I see you have posted to YT. That shows exactly what I got: if you freeze frame you see a “shadow” (“ghost”) of any moving bits and that’s where the flicker comes in.

      Maybe you can post an example up to a sharing sire like photobucket etc. Just a few seconds is all that is needed. It would really help. I just found that YT added another layer to the process: it shows the result, but the film has to be dl’d to evaluate, and that again changes things AFAICS. I found that my post up to YT was even worse than my results on my PC, and in fact ruined a perfect render “down here”

      So far I have not been able to avoid the jitters using any Progressive save (25p etc), if I render at 25fps.

      I can’t guarantee a result, as I do not have YT sorted yet. But I am getting there. I do have _some_ good results.

      Hope I can help sort us both out. I started to think I was going mad.

    • #195841
      AvatarAnonymous
      Inactive

      Hey Nick,

      This is a great start… thanks! I will run a few more 1min renders today or tonight and will report back. I didn’t know what the progressive save may do or not do, so I never touched that setting. I’ve done renders at native (or near native resolutions) with no luck – think I had to use WMV…?

      Anyway, I’ll check in as soon as I have some results.

      Cheers,

      Chris

    • #195842
      Avataroldnick
      Participant

      Well I have had a huge breakthrough. I asked on another forum, and I was told to set Resample to Disabled, if I was changing the frame rate. That left me with a Progressive output that was still not quite as smooth as the nicest interlaced results, but does get rid of the ghosting.

      Right click a video event. Switches from the popup menu. Then Disable resample.

      Just another thing to try. Works for me.

    • #195843
      Avataroldnick
      Participant

      In reply. There are several formats that allow 50fps. I cannot find one with 48fps. What results did you get with the higher speeds? Still ghosting?

      When you say you do not know what the Progressive setting does, do you mean that you _are_ using interlaced (Upper Field First, or Lower Field First) and you are getting ghosting anyway? I think not, because your Youtube post was without (what I think of as) interlacing lines. So I think your render is progressive.

      Try all the same settings and codecs, but using Interlaced in the Field Order entry field (some renders do not have it. Try Main Concepts Mpeg-2, HDV 720-25p, frame rate 24fps, then set the Field Order to Upper Frame First for starters). I would be interested to hear what happens.

      BTW. One minute renders are far too long when you are trying so many takes, IMO. You can see the problem in under 10 seconds of video and it saves a heap of render time. Even a couple of seconds often does for me and I usually work around 4-5.

      Nick

    • #195844
      Avataroldnick
      Participant

      Also, because of the lighting conditions, there could well be a shutter speed issue as well. As I said can you post up a few seconds of raw footage, and a few of a rendered version to a sharing site?

    • #195845
      AvatarAnonymous
      Inactive

      Sorry for the delay in my return… been rather busy. I had some time to play with some rendering settings and had no luck at all. Then I stumbled on this video tutorial and I think it’s the key to improving my poor results. It also suggested turning off the resampling! πŸ™‚

      I’m tweaking but am already seeing some better output: http://www.youtube.com/watch?v=6gzrlcLGCPA

Viewing 6 reply threads
  • You must be logged in to reply to this topic.

Best Products

Best Canon lenses β€” 2021

There are a number of Canon lenses on the market for both their DSLR and mirrorless cameras, these are our picks for EF, EF-S and RF mounts.
homicide-bootstrap