GL2 Rewinding Problem

  • This topic has 2 replies, 1 voice, and was last updated 12 years ago by AvatarAnonymous.
Viewing 2 reply threads
  • Author
    Posts
    • #45550
      AvatarAnonymous
      Inactive

      I bought a GL2 off of Ebay a few months ago. No problems at first, but recently, when rewinding a tape, the camera will suddenly freeze and the message “Eject Tape” will appear in the viewfinder. Sometimes the deck will rewind fine, but 2/3 of the time this happens. Very frustrating, as you can imagine. The tape deck works perfectly when playing a tape, the problem only arises during rewinding. Anyone have any ideas?

    • #189030
      AvatarAnonymous
      Inactive

      GL2s are notorious, for this problem. They use a defective transport mechanism. Your only option is to send it to the Canon repair facility, and have them replace the transport mechanism. If they do anything else, like they did with mine, it won’t fix the problem. If I remember correctly, they charged me $250. When you get it back, always use a seperate rewinder, to rewind your tapes.

    • #189031
      AvatarAnonymous
      Inactive

      Thanks for the info; that’s helpful to know. Hopefully, they’ve remedied this problem in their newer GL2 models.

Viewing 2 reply threads
  • You must be logged in to reply to this topic.

Best Products

The best royalty-free music and sound effects sites – 2021

Music and sound effects are a crucial part of any film or video project. Using royalty-free stock music in your next project is one way to cut costs without sacrificing quality.
homicide-bootstrap