Canon XL2 – tape won’t eject

Viewing 4 reply threads
  • Author
    Posts
    • #45747
      Avatarsftrevor
      Participant

      Hello

      My XL2 won’t eject the tape, and this is the second or third time this has happened to me. The window pops open after sliding the eject lever, but no movement with the tape casing. Before I’d just take out the battery and put it back in. That seemed to work. Now I’ve tried anything and everything. But it won’t budge. About two weeks ago I shot with a Canon XH-A1, and it did the same thing. I’ve searched the net regarding this issue, but haven’t come across any helpful info.

      Anyone have this problem before, or know the solution?

  • #189577
    AvatarEarlC
    Member

    I have to say there IS something a bit funky about the GL2, and other Canon models, where this happens, and it isn’t always the battery connection itself. I’m sure you’ve tried this but maybe try it again:

    When it happens to me on MY GL2, I firmly re-close the window, but first I give just a tiny nudge to the “push” marked spot on the inside tape carrier basket – nothing harsh, just a gentle nudge. Then, after closing the cover firmly, I push the eject button a bit firmer than usual, letting it hang a moment at the end of its movement before letting go. So far this has worked for me everytime.

    Two things: As you’ve suspected the battery occasionally could be not making good contact and turning the camera on will confirm if there’s any juice at all going into the system; also there is a remote possibility that the tape has managed (this time) to wrap around something in the tape path and you have a more serious problem. But (knock on wood) I’ve not encountered THAT particular problem in many years now using my GL2. I usually run a tape head cleaner through it at least once a month, or every 4th or 5th gig.

  • #189578
    Avatarsftrevor
    Participant

    thanks for the response. I let it sit overnight, and sure enough it ejected the next day on first try. The times that it got stuck I have had full charge in both my batteries, and could playback, forward, and rewind the tape with no problem. I’m just wondering if I should contact Canon since it’s still under warranty.

  • #189579
    AvatarEarlC
    Member

    You could contact the company being as you are covered under warranty, but it is likely they’ll not offer any joy. As I mentioned, this is an ongoing occurrence in mine and has so far only required a bit firmer push of the button to get it to respond properly. Canon isn’t likely to accept the occasional event of not opening as a “repairable” problem. If they did, about all they would do is blow it out with some canned air and maybe do a bit of lubricant in the proper places.

    Out of warranty, on the other hand, they’ll hit the owner for $250 to $360 to replace the tape transport system and do a thorough cleaning and adjusting. Trust me on this – been there, done that particularly with both of my XL1s.

  • #189580
    Avatarrgforester
    Participant

    I gave up using Canon Factory Service years ago to take care of my XL-1s’s — in and out of warranty. Instead, I ship all my video gear to Cameron Boyd — a very knowledgeable technicianat AV Repair near Gainesville, FL. The guy really knows his stuff and he probably has a pretty good idea what’s causing your problem. You can call him at (888) 453-4948 or contact him through his website: http://www.avrepair.com

  • Viewing 4 reply threads
    • You must be logged in to reply to this topic.

    Best Products

    homicide-bootstrap