A1U Problem

Viewing 0 reply threads
  • Author
    Posts
    • #44738
      Avatarjpsndtek
      Participant

      Howday everyone, I’m a brand new newbie to the site. Well, been searching and reading for a while now but first time registering and posting. Anyway, I’m having an issue with my A1U. It doesn’t work! It worked perfectly and then I went to turn it on and nothing. I took out the battery and reinstalled and got a split second white flash on the lcd and nothing else. If I push the reset button I get the same. Nothing at all through the viewfinder. No lights on anything, nothing. Tape mech doesn’t make a sound, nothing.

      Has anyone heard of this? It wasn’t dropped, it was just sitting in it’s padded case.

      I’ve tried different batteries, a/c power, etc. No change. It won’t charge batteries either it seems. It seems as if nothing is getting power but the screen does flash which leads me to believe that it is?

      I really need this camera for this weekend. I’m supposed to shoot an event in HD but may be stuck using the VX2000…

      Help? πŸ™

Viewing 0 reply threads
  • You must be logged in to reply to this topic.

Best Products

homicide-bootstrap